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’ PDFs

A pdf file is generally viewable and compatible with a wide variety

Itl.‘.d in l-Eﬂ!'II.illg mi of technologies, making it a good choice for a published document
ttnr, planse peovide L with & Bitthe Mformaton sl format when you are uncertain as to where your work is ultimately
re] your hockey needs. being viewed. Part of the appeal of a pdf is the ability to create fill-
_ able forms, making the document larger than just the information
" o nbri mi;}' printed on the page.
City, State, £IF: = rl
" | Setup fFor Creating Forms
nrecere- | What's pour e-mail address? I'ey
 about: The default workspace “Interactive for PDF” is an advantageous
choice to begin work on creating a form. Choose Window > Work-
our information. (g space > Interactive for PDF to have access to the panels you will
need.
Adding Fields
A form field is the basic unit of interaction within a fillable pdf. You
can either create frames and convert them into fields, or add fields
directly from a panel. For text fields, the most direct method is to
create the text frame, then use the Buttons and Forms panel to
convert it. For buttons, it is more direct to drag a sample button
from the Sample Buttons and Forms panel.
About Names Modifying Fields
Each field name must be unique. The The B'uttons.and Formsf panel allow; you to change the properties
output of a filled form consists of field of a field object, and will rearrange its contents depending on what
names and field contents. When a user kind of field you have. All fields have at least the following proper-
fills in a text box or clicks a check, that ties:
stores a value in the matching field «  field type: text box, list box, check box, combo box, radio but-
r)ame..Exarnple output of a form looks ton etc.
like this: ' . e . .
Field Name: Field Value + name: the identifying quality of a form object, each name must
be unique
First Name: Ingrid Fields may optionally have a description, which helps guide the
Last Name: Designer user to fill out the form, and any of many other options depend-
Mailing List: Yes . ing on the field type, all selectable within the Buttons and Forms
Text1: Lorem ipsum dolor sit amet
Text2: requiescat in pace panel.
Preferred Days: M,R,F,S
Field Groups
A radio button group allows the user to select only one out of a

list of options. Each component object of a radio button group
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Tab order allows users to use the tab
key to move between fields of a fillable
form. The default tab order matches
the order in which you added the fields
to the layout. You can change this order
by going to Object > Interactive > Set
Tab Order

mailto:

The mailto action relies on the user’s
own configuration for default email cli-
ent, so you may not always want to use
a submit button, but instead include in-
structions to the user to send an email
with the completed form attached.

can be any kind of object. To = _ g
make several buttons part of g - ettums and Forms [ Beakmarks | -
group, they each must have the TR aein b

same field name. The field value
setting allows each individual
button to represent one of the
set of mutually exclusive choic-
es for that radio button group.
The sample radio groups in the
Sample Buttons and Forms panel
have three buttons, and you can  Asssrars

add more simply by dragging El SRS
another group over, making sure |+ =
to change the field name of each |# || matenrom
to be the same. - [i] IClich Omb
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Submit Button

You can add a submit action to e nerptian
a button using the Buttons and
Forms panel. The most common
submit action is called mailto, e
and will generate an email with — esmss valee chece
the field contents and send it to

the address you specify. = W 3

w POF Cano=s

o prinaabie Reas Only
Sebt ber tifdl By ol Pl ®

Exporting the PDF

It is important to choose the Export command rather than the Save
command when creating a fillable PDF. Choose File > Export, and
then choose the Adobe PDF (Interactive) file type for export. This
will present a dialog box with an array of options for how you will
create the form. If you do not have the Include All button selected
in the Forms and Media line, your pdf will not be fillable, so it is
important to select it.

Global Styles

You have already worked with styles within the context of a single
frame. Styles are a means of establishing a uniform look across an
entire document or even several documents. Learning how to use
styles as a global (rather than local) resource will help speed up
your workflow and save you time when editing.
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The different style panels have individ-
ual load commands, called Load Object
Styles in the case of objects, Load Char-
acter Styles in the case of characters,
and Load Paragraph Styles in the case
of paragraphs. From either the para-
graph or character style panels, you can
also select “Load All Text Styles,” which
loads character and paragraph styles at
the same time.

To track changes in the story editor,
choose Type > Track Changes > Track
Changes in Current Story. Changes will
show up with an orange highlight after
that selection. Accepting a change
clears the change track highlight, but
does not alter the document. Rejecting
a change reverts the document to its
previous state.

Updating Styles

There are two ways to globally update a style in your document,
whether it is a character, paragraph, or object style.

A Select the object (or character or paragraph), make changes,
then choose “Redefine Style” from the overridden style in the pan-
el right-click menu.

B Double-click on the style in the panelitself to open a dialog
box and select the changes you want.

In either case, all objects that share the style you changed will up-
date with the selected changes. If an object has an override, a plus
sign (+) will appear next to the style name in the panel. You can
revert the object to the base style by selecting “Clear Overrides”
from the right-click menu.

External Styles

Styles get saved along with an InDesign document. You can reuse
styles you have created in other documents by loading them into
an open document. Click on the panel menu for in a style panel,
then select the Load command. Choose the indd document that
has the styles you want. You will get a dialog box that lets you
choose from among the available styles in the source document.

Finding a Font

Sometimes when you open a document on a new computer, the
fonts that document uses will be missing. Fonts are stored on
computers themselves, and not always bundled into the document.
If you find you have a missing font, you can either open the Find
Fonts dialog box from the Missing Font warning message at open-
ing time, or use the menu command Type > Find Font, which will
open the same dialog box. This will let you quickly identify and cor-
rect missing fonts in the document, or select alternatives that will
apply across styles throughout the document all at the same time.

Story Editor

Once you have layout and style settings managed, you may want
a way to perform basic text editing without the distractions that
the finished presentation can cause. The Story Editor allows you to
see a structural view of the text within a selected frame, and even
make edits. This view will indicate where text is overset, what non-
printing characters appear in the copy, and where tracked changes
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The Story Editor

have occurred.

To turn on the Story Editor, choose the menu command Edit > Edit
in Story Editor. If you wish to see all special characters including
nonprinting characters, click on the view options button in
the application bar and check Hidden Characters. You can change
options about the Story Editor by going to View > Story Editor.

Find and Replace

The Find and Replace feature allows you to quickly locate bits of
text or styles in your open document, or even across all open docu-
ments. To access this feature, choose Edit > Find/Replace.

Spellcheck

Before you finalize and distribute any publication, it is usually a
good idea to run a spellchecker. InDesign comes equipped with a
robust spellchecker that allows you to customize options, ignore
words, add entries to a custom dictionary and more. To access this
feature, choose Edit > Spelling > Check Spelling.

Book Editing

The needs of a complete book are somewhat greater than those
of a single document (like a pdf or magazine article). InDesign has
tools to manage chapter structure and publishing settings for
books and other long documents.

Starting a Book

In InDesign, a book is a collection of documents. To begin, choose
File > New > Book. Unlike other documents, you first save a book
file, and then add material to it. The New dialog box will provide
some options for how to structure your book.

Adding Chapters

Single document component pieces of a book are called chapters.
To add a chapter to your book, use the Book panel menu and select
Add Document. If you already have several chapters completed,
you can add them all at once.

Book Panel

With several chapters loaded, you can use the Book panel to reor-
der, add, remove, and change options for your chapters. Much of
this happens without looking at specific documents; the panel only
contains links to the documents, not the documents themselves. If
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you double-click on a chapter, InDesign will open that file and allow
you to make edits as you did with any document you have worked
with so far.

From there, the Book panel menu contains the options you will
need to edit the whole book, including page numbering.

Text Variables

To create a running header or footer that automatically updates
with the chapter title, you can create a text variable. Within a spe-
cific chapter, choose Type > Text Variables > Define. This dialog box
lets you create the variable and specify options for it (For example,
what paragraph style it should use).

Next, place the insertion point in the desired place on the master
page of the document (either in the header or footer area), and
choose Type > Text Variables > Insert Variable, and then choose the
name of the text variable you created.

You can reuse this variable within the other chapters to quickly put
the chapter title in the header or footer. Afterward, these variables
will automatically update from the chapter titles you create, so you
only need to edit each chapter master page once.

Automatic Text

InDesign can create an automatic table of contents or index for
your document, so you do not need to type out page numbers or
index entries by hand. These fields will also automatically update in
case page numbers or reference text changes later.

The table of contents keys off of styles you have chosen to rep-
resent outline levels. Using consistent paragraph styles for your
headings throughout all the chapters of a book is a prerequisite

to building a meaningful table of contents. Once you do have

your outline level styles synchronized, choose Layout > Table of
Contents. This dialog will let you choose which paragraph styles
represent headings, and also other options for the table. Wherever
a paragraph with the chosen style appears, the table will have an
entry with matching page number. Completing this command will
load a table of contents onto the pointer, like placing a document.
You can then manage it as you would any placed document.

To update a table of contents after making changes, select the text
frame that contains the table of contents, and use the menu com-
mand Layout > Update Table of Contents.
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Wrap-up

Upon completing this workshop, you should be able to do the
following:

« Convert an object into a PDF form field

e Assign a submit action in a PDF

« Globally update a style

« Load styles from another source

« Find a missing font

« Edit a text frame in the story editor

e Check spelling and track changes

« Build a book from multiple documents

« Add an automatic table of contents or index
« Create running headers and footers




