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About Symbols

A symbol is a graphic, button, or movie clip that you create once in 
the Flash Professional authoring environment or by using the  
SimpleButton (AS 3.0) and MovieClip classes. You can then reuse 
the symbol throughout your document or in other documents.

A symbol can include artwork that you import from another  
application. Any symbol that you create automatically becomes 
part of the library for the current document.

An instance is a copy of a symbol located on the Stage or nested 
inside another symbol. An instance can be different from its  
parent symbol in color, size, and function. Editing the symbol  
updates all of its instances, but applying effects to an instance of a 
symbol updates only that instance.

Using symbols in your documents dramatically reduces file size; 
saving several instances of a symbol requires less storage space 
than saving multiple copies of the contents of the symbol. For  
example, you can reduce the file size of your documents by  
converting static graphics, such as background images, into  
symbols and then reusing them. Using symbols can also speed SWF 
file playback, because a symbol needs to be downloaded to  
Flash® Player only once.

Share symbols among documents as shared library assets during 
authoring or at runtime. For runtime shared assets, you can link 
assets in a source document to any number of destination  
documents, without importing the assets into the destination 
document. For assets shared during authoring, you can update 
or replace a symbol with any other symbol available on your local 
network.

If you import library assets with the same name as assets already in 
the library, you can resolve naming conflicts without accidentally 
overwriting existing assets.
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Types of symbols
Each symbol has a unique Timeline and Stage, complete with  
layers. You can add frames, keyframes, and layers to a symbol 
Timeline, just as you can to the main Timeline. When you create a 
symbol you choose the symbol type.

Use graphic symbols  for static images and to create reusable  
pieces of animation that are tied to the main Timeline. Graphic 
symbols operate in sync with the main Timeline. Interactive  
controls and sounds won’t work in a graphic symbol’s animation  
sequence. Graphic symbols add less to the FLA file size than  
buttons or movie clips because they have no timeline.

Use button symbols  to create interactive buttons that respond to 
mouse clicks, rollovers, or other actions. You define the graphics 
associated with various button states, and then assign actions to 
a button instance. For more information, see Handling events in 
Learning ActionScript 2.0 in Adobe Flash or Handling events in the 
ActionScript 3.0 Developer’s Guide.

Use movie clip symbols  to create reusable pieces of animation. 
Movie clips have their own multiframe Timeline that is  
independent from the main Timeline—think of them as nested  
inside a main Timeline that can contain interactive controls, sounds, 
and even other movie clip instances. You can also place movie clip  
instances inside the Timeline of a button symbol to create 
animated buttons. In addition, movie clips are scriptable with  
ActionScript®.

Use font symbols to export a font and use it in other Flash  
Professional documents.

Flash Professional provides built‑in components, movie clips with 
defined parameters, that you can use to add user interface  
elements, such as buttons, checkboxes, or scroll bars, to your  
documents. For more information, see About Components in Using 
ActionScript 2.0 Components, or About ActionScript 3.0  
Components in Using ActionScript 3.0 Components.

Note: To preview animation in component in-
stances and scaling of 9-slice-scaled movie clips 
in the Flash Professional authoring environ-
ment, select Control > Enable Live Preview.
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Create symbols

You can create a symbol from selected objects on the Stage, create 
an empty symbol and make or import the content in  
symbol-editing mode, and create font symbols in Flash  
Professional. Symbols can contain all the functionality that Flash 
Professional can create, including animation.

Using symbols that contain animation lets you create Flash  
Professional applications with a lot of movement while minimizing 
file size. Consider creating animation in a symbol that has a  
repetitive or cyclic action—the up‑and‑down motion of a bird’s 
wings, for example.

To add symbols to your document, use shared library assets during 
authoring or at runtime.

Convert selected elements to a symbol
Select an element or several elements on the Stage. Do one of the 
following:
Select Modify > Convert To Symbol.

Drag the selection to the Library panel.

Right-click (Windows) or Control-click (Macintosh) and select  
Convert To Symbol from the context menu.

In the Convert To Symbol dialog box, type the name of the symbol 
and select the behavior.
Click in the registration grid to position the registration point for 
the symbol.
Click OK.
Flash Professional adds the symbol to the library. The selection 
on the Stage becomes an instance of the symbol. Once you have 
created a symbol, you can edit it in symbol edit mode by choosing 
Edit > Edit Symbols, or you can edit it in the context of the Stage by 
choosing Edit > Edit In Place. You can also change the registration 
point of a symbol.
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Create an empty symbol

Do one of the following:
•	 Select Insert > New Symbol. 

•	 Click the New Symbol button at the lower left of the Library 
panel. 

•	 Select New Symbol from the Library Panel menu in the up‑
per-right corner of the Library panel. 

•	 In the Create New Symbol dialog box, type the name of the 
symbol and select the behavior. 

•	 Click OK. 

Flash Professional adds the symbol to the library and switches to 
symbol-editing mode. In symbol-editing mode, the name of the 
symbol appears above the upper-left corner of the Stage, and a 
cross hair indicates the symbol’s registration point.

To create the symbol content, use the Timeline, draw with the 
drawing tools, import media, or create instances of other symbols.
To return to document-editing mode, do one of the following:
•	 Click the Back button. 

•	 Select Edit > Edit Document. 

•	 Click the scene name in the Edit bar.

When you create a symbol, the registration point is placed at the 
center of the window in symbol-editing mode. You can place the 
symbol contents in the window in relation to the registration point. 
To change the registration point, when you edit a symbol, move 
the symbol contents in relation to the registration point.

In the ActionScript Linkage section, you can choose to export for 
ActionScript by selecting the Export for ActionScript checkbox. The 
Class and Base Class are automatically displayed (you can choose 
to rename the class names). Flash Pro searches for class definitions 
in an external AS file or a linked SWC file. If the class definitions 
are not found in these locations, Flash Pro automatically generates 
class files.  

(Flash Professional CC only) Swapping 
multiple symbols
The Swap Symbol option allows you to 
swap symbols with a selected symbol or 
bitmaps.

In Flash Pro CC, select multiple symbols 
on the stage.
On the Properties panel, click SWAP.
On the Swap Symbol dialog, select the 
symbol you want to replace all selected 
symbols/bitmaps with.
Click OK.
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Convert animation on the Stage into a 
movie clip symbol

To reuse an animated sequence on the Stage, or to manipulate it as 
an instance, select it and save it as a movie clip symbol.

On the main Timeline, select every frame in every layer of the 
animation on the Stage that you want to use. For information on 
selecting frames, see Insert frames in the Timeline.
Do one of the following to copy the frames:
Right-click (Windows) or Control-click (Macintosh) any selected 
frame, and select Copy Frames from the context menu. To delete 
the sequence after converting it to a movie clip, select Cut.

Select Edit > Timeline > Copy Frames. To delete the sequence after 
converting it to a movie clip, select Cut Frames.

Deselect your selection and make sure nothing on the Stage is  
selected. Select Insert > New Symbol.
Name the symbol. For Type, select Movie Clip, then click OK.
On the Timeline, click Frame 1 on Layer 1, and select  
Edit > Timeline > Paste Frames.
This action pastes the frames (and any layers and layer names) you 
copied from the main Timeline to the Timeline of this movie clip 
symbol. Any animation, buttons, or interactivity from the frames 
you copied now becomes an independent animation (a movie clip 
symbol) that you can reuse.

To return to document-editing mode, 
do one of the following:
Click the Back button.

Select Edit > Edit Document.

Click the scene name in the Edit bar 
above the Stage.

Duplicate symbols
Duplicating a symbol lets you use an 
existing symbol as a starting point for 
creating a symbol.

To create versions of the symbol with 
different appearances, also use 
instances.

Duplicate a symbol using the Library 
panel
 Select a symbol in the Library panel 
and do one of the following:
Right-click (Windows) or Control-click 
(Macintosh), and select Duplicate from 
the context menu.

Select Duplicate from the Library Panel 
menu.

Duplicate a symbol by selecting an 
instance
Select an instance of the symbol on the 
Stage.
Select Modify > Symbol > Duplicate 
Symbol.
The symbol is duplicated, and the 
instance is replaced with an instance of 
the duplicate symbol.
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Edit Symbols

When you edit a symbol, Flash Professional updates all the  
instances of that symbol in your document. Edit the symbol in the 
following ways:
•	 In context with the other objects on the Stage by using the Edit 

In Place command. Other objects are dimmed to distinguish 
them from the symbol you are editing. The name of the symbol 
you are editing appears in an Edit bar at the top of the Stage, to 
the right of the current scene name. 

•	 In a separate window, using the Edit In New Window command. 
Editing a symbol in a separate window lets you see the  
symbol and the main Timeline at the same time. The name of 
the symbol you are editing appears in the Edit bar at the top of 
the Stage. 
 
You edit the symbol by changing the window from the Stage 
view to a view of only the symbol, using symbol-editing mode. 
The name of the symbol you are editing appears in the Edit bar 
at the top of the Stage, to the right of the current scene name. 
 
When you edit a symbol, Flash Professional updates all  
instances of the symbol throughout the document to reflect 
your edits. While editing a symbol, use any of the drawing tools, 
import media, or create instances of other symbols. 

•	 Change the registration point of a symbol (the point identified 
by the coordinates 0, 0) by using any symbol-editing method.

Edit the symbol.
To exit symbol-editing mode and return to editing the document, 
do one of the following:
Click the Back button at the left of the Edit bar at the top of the 
Stage.

Select Edit > Edit Document.

Click the scene name in the Edit bar at the top of the Stage.

Double-click outside the symbol content.

Edit a symbol in place
Do one of the following:
Double-click an instance of the symbol 
on the Stage.

Select an instance of the symbol on 
the Stage and right-click (Windows) or 
Control-click (Macintosh), and select 
Edit in Place.

Select an instance of the symbol on the 
Stage, and select Edit > Edit In Place.

Edit the symbol.
To exit edit-in-place mode and return to 
document-editing mode, do one of the 
following:
Click the Back button.

Select the current scene name from the 
Scene menu in the Edit bar.

Select Edit > Edit Document.

Double-click outside the symbol  
content.

Edit a symbol in a new window
Select an instance of the symbol on the 
Stage and right-click (Windows) or  
Control-click (Macintosh), and select 
Edit In New Window.
Edit the symbol.
Click the Close box in the upper-right 
corner (Windows) or upper-left corner 
(Macintosh) to close the new window, 
and click in the main document window 
to return to editing the main docu‑
ment.
Edit a symbol in symbol-editing mode
Do one of the following to select the 
symbol:
Double-click the symbol’s icon in the 
Library panel.
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Buttons

There are three types of symbols in Adobe Flash Professional: but‑
tons, graphics, and movie clips. Button symbols enable you to add 
interactivity to your projects, including rollover and  
disjointed rollover effects, in addition to triggering functions. 
There are two parts of a button’s behavior: the first is how the  
button itself behaves visually when rolled over or clicked; the  
second is what happens in the Flash file when the button is clicked.

Most buttons are designed with different Up, Down, and Over 
states. These states allow the button to look different when the 
user hovers the cursor over the button and when user clicks the 
button.

Buttons in Flash always require ActionScript to cause mouse events 
(such as mouseover or onclick) to trigger actions and run functions. 
In order to hook up buttons to the corresponding ActionScript, you 
must assign an instance name to button instances on the Stage 
using the Property inspector.

There are several different ways of creating buttons. Choose from 
the following:

•	 Button symbols
•	 Movie Clip symbols
•	 ActionScript 3 Button components
•	 ActionScript 2 Button components
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Basic steps for creating buttons
Decide what button type best suits your needs.

Button symbol
Most people choose button symbols for their flexibility. Button 
symbols contain a specialized internal timeline for button states. 
You can easily create visually different Up, Down, and Over states. 
Button symbols also change their state automatically as they react 
to user actions.

Movie clip button
You can use a movie clip symbol to create sophisticated button 
effects. Movie clip symbols can contain almost any type of content, 
including animation. However, movie clip symbols do not have 
built-in Up, Down, and Over states. You create those states your‑
self, using ActionScript. A disadvantage is that movie clip files are 
larger than button files. 

ActionScript button component
Use a button component if you require only a standard button or a 
toggle, and you don’t want to customize it extensively. Both  
ActionScript 2.0 and 3.0 button components come with built-in 
code that enables state changes. So, you don’t have to define the 
look and behavior of button states. Simply drag the component 
onto the Stage.

ActionScript 3.0 button components allow for some  
customization. You can bind the button to other components, and 
share and display application data. They have built-in features, such 
as accessibility support. Button, RadioButton, and CheckBox  
components are available. For details, see Use the Button  
component in Using Adobe ActionScript 3.0 Components.
ActionScript 2.0 button components are not customizable. The 
component enables state changes. 

Associate an action with the button.
To make something happen when the user selects a button, you 
add ActionScript code to the Timeline. Place the ActionScript code 
in the same frames as the buttons. The Code Snippets panel has 
pre-written ActionScript 3.0 code for many common button uses. 

Define your button 
states.
Up frame
The appearance of the button when 
the user is not interacting with it.

Over frame
The appearance of the button as the 
user is about to select it.

Down frame
The appearance of the button as the 
user selects it.

Hit frame
The area that is responsive to clicks 
by the user. Defining this Hit frame is 
optional. If your button is small, or if its 
graphic area is not contiguous, defining 
this frame can be useful.

The contents of the Hit frame are not 
visible on the Stage during playback.

The graphic for the Hit frame is a solid 
area large enough to encompass all 
graphic elements of the Up, Down, and 
Over frames.

If you don’t specify a Hit frame, the 
image for the Up state is used.

You can make a button that responds 
when a different area of the stage 
is clicked or rolled over (also called a 
disjoint rollover). Place the Hit frame 
graphic in a different location than the 
other button frame graphics.

Note:
ActionScript 2.0 is not compatible with 
ActionScript 3.0. If your version of Flash uses 
ActionScript 3.0, you can’t paste ActionScript 
2.0 code into your button (and vice versa). 
Before you paste ActionScript from another 
source into your buttons, verify that the version 
is compatible.
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Adobe ActionScript 
is the scripting language used in Adobe Flash Professional to  
control playback of SWFs at runtime in Adobe Flash Player. Use 
ActionScript to make your applications play dynamically in a  
nonlinear way, and to add interesting or complicated functionality 
that cannot be added using the Timeline.

Using ActionScript, you can add complex interactivity, playback 
control, and data display to your application. You can add  
ActionScript in the authoring environment by typing code into the 
Script pane of the Actions panel. ActionScript follows its own rules 
of syntax, uses reserved keywords, and supports variables (used to 
store and retrieve information). ActionScript includes a large library 
of built‑in classes that you can use to create objects that perform 
many useful tasks, such as generating random numbers.

When you create a new FLA document, you must choose which 
version of ActionScript to use. You can change this setting if you 
decide later to write your scripts using a different version of  
ActionScript by updating the publish settings.

Flash supports several versions of ActionScript to meet the needs 
of different kinds of developers and playback hardware:

ActionScript 3 (the most recent version) executes extremely fast 
and is fully compliant with the ECMAScript specification. It offers 
better XML processing, an improved event model, and an improved 
architecture for working with onscreen elements. FLA files that use 
ActionScript 3 cannot include earlier versions of ActionScript.
ActionScript 2 is older and simpler to learn than ActionScript 3.  
Although Flash Player runs compiled ActionScript 2 code slower 
than compiled ActionScript 3 code, ActionScript 2 is still useful for 
many kinds of projects that are not computationally intensive—
such as design-oriented content.
ActionScript 1 is the simplest form of ActionScript, and is still used 
by some versions of the Flash Lite player. ActionScript 1 and 2 can 
coexist in the same FLA file.
Flash Lite 2 and Flash Lite 1 are subsets of the corresponding 
version of ActionScript that are supported on some older mobile 
phones and devices.

Note: Most things that you can do in Flash 
can be done with or without ActionScript. The 
things that actually require ActionScript are 
nonlinear playback and any situation where you 
choose to avoid using the Timeline.
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ActionScript example

Different features and file formats may require setting the corre‑
sponding version of ActionScript in the publish profile in order to 
function and render properly.
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Patterns

Like gradients, patterns can be used to add interest to otherwise 
flat graphic shapes. Adobe Flash Professional CS5 provides a  
handful of options for creating patterns, including the new  
enhancements to the Deco tool.

A tile is a bitmap, symbol, or shape applied as a repeating graphic 
element to form a pattern effect. You can think of repeating  
graphics like tiles on a floor forming a pattern in a room. In Flash 
Professional, you can apply bitmaps as tiled fills using the Color 
panel. You can also apply movie clip symbols as tiled patterns using 
the Spray Brush and Deco tools.

Bitmap fills
Bitmaps can be used to fill shapes with repeating patterns. You can 
use the Color panel or the Graphics object in ActionScript to draw 
bitmaps inside the fills and strokes in your drawing objects. The 
bitmaps are applied to the shape as a repeating pattern which can 
be manipulated with the Gradient Transform tool to create a  
geometric grid pattern.

To create a shape containing a bitmap fill:

1.	 Create a bitmap graphic in Adobe Fireworks or a similar  
graphics editing program.

2.	 Size the graphic to approximately 120 pixels (or less) in width 
and height.

3.	 Save the file in the PNG, JPEG, or GIF format.
4.	 Create a new FLA file in Flash named bitmapfill.fla.
5.	 Draw a shape on the Stage using the Rectangle tool (R) or  

another shape tool.
6.	 Select the shape and open the Color panel (Window > Color).
7.	 Make sure the fill color swatch is selected in the Color panel and 

change the fill option from Solid color to Bitmap fill 
8.	 Click the Import button in the Bitmap fill options and import 

your bitmap. Notice that the bitmap is imported to the Library 
panel and displayed in a grid inside the fill area of your shape.

9.	 Select the Gradient Transform tool (F) and then click on one 
of the tiles in the pattern. Notice that transformation handles 
appear over the single tile graphic. Rotate, scale, and skew the 
tile until you’ve achieved the desired effect.

10.	Save the file.
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You can apply a bitmap fill to the stroke of the shape as well. If 
you need to change the effect, use the Gradient Transform tool to 
remove the effect by changing the fill option setting in the Color 
panel.

Spray Brush and Deco tools

The Spray Brush and Deco tools can be used to create a wide range 
of pattern effects utilizing the procedural modeling engine that 
was first available in Flash CS4 Professional. The procedural  
modeling engine is a Flash JavaScript (JSFL) library that processes 
geometric algorithms to generate patterns. JSFL is used by Adobe 
and third-party developers to create custom tools in Flash.

Spray brush

The Spray Brush tool (B) can be used to spray a random pattern of 
shapes as you draw with the brush on the Stage. The Spray Brush 
tool is grouped with the Brush tool in the Tools panel  
(see Figure 3). Configure the drawing options in the Properties 
panel while the Spray Brush tool is selected. Click and paint with 
the brush on the Stage to see the effect.

Transforming a tile within the bitmap 
fill grid.

Figure 3. Spray Brush tool in the Tools 
panel and the related options in the 
Properties panel.

Flash Professional CS5 expands the 
capabilities of the Deco tool by adding 
a new range of effects. You can easily 
generate unique graphics such as  
buildings, trees, flowers, fire, smoke, 
and lighting. You can also create  
symmetrical geometric patterns as a 
shortcut for creating complex  
repeating patterns of shapes.
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Deco tool

The Deco tool (U) can be used to create geometric graphic effects 
and special effects such as lighting, smoke, and fire. You can access 
the Deco tool in the Tools panel and use the Drawing Effect menu 
in the Properties panel to choose from a range of different effects 

To use the Deco tool, select the drawing effect and options in the 
Properties panel and then click (or click and drag) the tool on the 
Stage to create the pattern effect.

Custom graphics with the decorative tools

Either use the default settings for the Spray Brush and Deco tools 
or create your own movie clip symbols to use as tiles in the pattern. 
By using your own custom symbols, you can create infinite varia‑
tions in the range of effects.

The following tools and effects support custom symbols:

1.	 Spray Brush tool
2.	 Deco tool (Vine Fill, Grid Fill, Symmetry Brush, 3D Brush, Particle 

System)
3.	 To select a custom symbol, click the Edit button next to the 

<no symbol> field in the Properties panel while the Deco tool is 
selected (see Figure 5).

After you add your custom symbols, you can edit the effect using 
the options in the Properties panel and then apply the effect using 
the Deco tool on the Stage.

Animating Deco tool patterns

You can animate Deco tool patterns by converting them to a 
 symbol and then animating them as you would any other  
graphic. Add blur effects and filters as well as tweens to enhance 
the effects. In the case of the Fire Animation, Smoke Animation, 
and Particle System effects, the Deco tool dynamically generates 
the animation.

Figure 5. Particle System effect’s  
custom symbol options.
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Wrap-up 
By the end of this workshop, you should be able to: 

•	 Understand and create Symbols
•	 How to create and edit a Button
•	 Understand ActionScript
•	 Able to use the Deco Tool


