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Importing Word documents
	
In	an	effort	to	create	efficient	workflows,	Adobe	has	integrated	
Dreamweaver	with	many	other	programs	that	you	or	your	team	
members	are	likely	to	use.	Most	integration	is	understandably
within	Adobe’s	Creative	Suite,	but	other	programs	like	Word	
feature	differing	levels	of	integration	as	well.	It’s	not	often	that	I	
have	to	break	bad	news	to	Mac	folks,	but	this	is	sadly	one	of	those	
times.	The	integration	between	Word	and	Dreamweaver	that	I’m	
about	to	show	you	only	works	on	the	PC	version	of	Dreamweaver.	
Still,	the	Mac	folks	should	keep	reading	no	need	to	skip	this,	
because	there	is	one	option	in	the	following	example	that	does	
work	for	you	and	it’s	something	you	might	want	to	take	advantage	
of	later	on.

The	first	thing	is	to	go	to	the	Menu	option,	go	to	File	and	choose	
Import	you	will	notice	that	one	of	the	options	in	Import	is	to	import	
a	Word	document.	So	rather	than	copying	and	pasting,	I	can	just	
import	the	Word	Document.

As	soon	as	I	do	that	it	just	takes	its	content	and	drops	it	right	into	

Changing the Copy/
Paste Prefences in
Dreamweaver
You	can	set	special	paste	preferences	as	
default	options	when	using		
Edit	>	Paste	to	paste	text	from	other	
applications.	For	example,	if	you	always	
want	to	paste	text	as	text	only,	or	text	
with	basic	formatting,	you	can	set	the	
default	option	in	the	Copy/Paste	Prefer-
ences	dialog	box.

Note: When you paste text into a 
Dreamweaver document, you can use 
either the Paste or the Paste Special 
command. The Paste Special command 
lets you specify the format of pasted 
text in different ways.	
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the	area	that	I	have	selected.	How	cool	is	that?	It’s	a	very	quick,	it’s	
very	easy.	Now	one	of	the	things	that	you	are	going	to	notice	about	
this	is	it	didn’t	prompt	me	in	terms	of	how	it	wanted	to	process	this	
copy	and	bring	it	in.	It’s	basing	its	settings	off	of	the	preferences	
that	I	have	set	in	the	copy	and	paste	preferences.	So	if	you’re	look-
ing	for	a	prompt,	if	you	ever	want	to	change	that,	you	either	need	
to	change	the	preferences	before	you	do	the	import,	or	you	need	
to	use	the	second	method	
So	if	I	undo	this	and	I	go	over	to	my	Files	panel,	actually	grab	the

.doc	file	and	drag	and	drop	it	into	the	region	that	I	want	the	text	to		
	
appear	in.	As	soon	as	you	let	go	of	the	mouse,	your	preferences	will	
come	up	and	now	Dreamweaver	is	actually	prompting	you	in	say-
ing,	okay,	well	how	do	you	want	to	inset	this?	You	will	notice	it’s	the	
exact	same	preferences	that	you	have	within	your	Copy	and	Paste	
preferences	except	for	one	down	here	on	the	bottom.	
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Now	I	am	going	to	come	back	to	this	option	in	just	a	moment.		
So	when	I	click	OK,	you	will	notice	I	get	the	exact	same	results,	the	
text	comes	in	and	it’s	formatted	exactly	the	way	I	want	to	format	it	
based	upon	structure	that	it’s	grabbing	from	the	Word	Document	
and	the	styles	that	I	have	applied	to	my	site.	That	last	option,	I	
want	to	talk	to	you	about	that	for	just	a	moment.	What	if	you	had	
a	Word	Document	that	you	wanted	to	give	the	users	of	your	site	
an	option	to	download?	So	if	I	go	to	the	next	line	here	for	example,	
and	just	create	sort	of	an	empty	paragraph	over	there,	well	if	go	
over	to	the	Files	panel	and	I	grab	the	Word	document	and	I	drag	it	
to	that	empty	paragraph,	I	can	choose	this	last	option	which	is	to	
Create	a	link.

Now	for	you	guys	that	are	on	the	Mac,	this	is	the	option	that	works	
for	you.	So	although,	it’s	not	going	to	bring	in	the	content	as	quick-
ly	and	easily	as	it	will	for	PC	users,	if	you	want	to	give	people	the	
option	of	clicking	and	downloading	this	file	to	their	hard	drive,	you	
can	use	this	option	to	Create	a	link.	It	uses	the	title	of	the		
document	and	it	just	creates	a	link	to	that,	and	of	course	you	can	
change	to	the	text.
You	can	say	something	like	download	the	programs	word	doc.	That	
would	prompt	people	when	they	click	that	to	download	the		
document	to	the	local	hard	drive.	So	there	you	go,	that’s	it,	it’s	
quick	and	easy.	What’s	easier	than	dragging	and	dropping	right?	
Now	I’m	sorry	to	say	this	feature	doesn’t	work	on	the	Mac.	But	do	
take	note	of	the	fact	that	if	you	want	to	link	to	an	external	Word	
file	for	users	of	your	site	to	download,	it	as	easy	as	dragging	and	
dropping	as	well.

Note: The user interface has been simpli-
fied in Dreamweaver CC and later. As a re-
sult, you may not find some of the options 
described in this handout in Dreamweaver 
CC and later.
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About tables

Tables	are	a	powerful	tool	for	presenting	tabular	data	and	for	
laying	out	text	and	graphics	on	an	HTML	page.	A	table	consists	of	
one	or	more	rows;	each	row	consists	of	one	or	more	cells.	Although	
columns	aren’t	usually	explicitly	specified	in	HTML	code,	
Dreamweaver	enables	you	to	manipulate	columns	as	well	as	rows	
and	cells.

Dreamweaver	displays	the	table	width	and	the	column	width	for	
each	table	column	when	the	table	is	selected	or	when	the	insertion	
point	is	in	the	table.	Next	to	the	widths	are	arrows	for	the	table	
header	menu	and	the	column	header	menus.	Use	the	menus	for	
quick	access	to	common	table-related	commands.	You	can	enable	
or	disable	the	widths	and	menus.

If	you	do	not	see	a	width	for	the	table	or	for	a	column,	then	that	
table	or	column	does	not	have	a	specified	width	in	the	HTML	code.	
If	two	numbers	appear,	then	the	visual	width	as	it	appears	in	De-
sign	view	doesn’t	match	the	width	specified	in	the	HTML	code.	This	
can	happen	when	you	resize	a	table	by	dragging	its	lower-right	
corner	or	when	you	add	content	to	a	cell	that’s	larger	than	its	set	
width.

For	example,	if	you	set	a	column’s	width	to	200	pixels	and	then	
add	content	that	stretches	the	width	to	250	pixels,	two	numbers	
appear	for	that	column:	200	(the	width	specified	in	the	code)	and	
(250)	in	parentheses	(the	visual	width	of	the	column	as	it’s	
rendered	on	your	screen).
Note: You can also lay out your pages using CSS positioning.
 
Table formatting precedence in HTML

When	formatting	tables	in	Design	view,	you	can	set	properties	for	
the	entire	table	or	for	selected	rows,	columns,	or	cells	in	the	table.	
When	a	property,	such	as	background	color	or	alignment,	is	set	to	
one	value	for	the	whole	table	and	another	value	for	individual	cells,	
cell	formatting	takes	precedence	over	row	formatting,	which	in	
turn	takes	precedence	over	table	formatting.

The	order	of	precedence	for	table	
formatting	is	as	follows:

Cells
Rows
Table	

For	example,	if	you	set	the	background	
color	for	a	single	cell	to	blue,	then	set	
the	background	color	of	the	entire	
table	to	yellow,	the	blue	cell	does	not	
change	to	yellow,	since	cell	formatting	
takes	precedence	over	table	
formatting.
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Note:	When	you	set	properties	on	a	column,	Dreamweaver	changes	
the	attributes	of	the	td	tag	corresponding	to	each	cell	in	the		
column.

About splitting and merging table cells

You	can	merge	any	number	of	adjacent	cells—as	long	as	the	entire	
selection	is	a	line	or	a	rectangle	of	cells—to	produce	a	single	cell	
that	spans	several	columns	or	rows.	You	can	split	a	cell	into	any	
number	of	rows	or	columns,	regardless	of	whether	it	was	previ-
ously	merged.	Dreamweaver	automatically	restructures	the	table	
(adding	any	necessary	colspan	or	rowspan	attributes)	to	create	the	
specified	arrangement.

In	the	following	example,	the	cells	in	the	middle	of	the	first	two	
rows	have	been	merged	into	a	single	cell	that	spans	two	rows.

Insert	a	table	and	add	content
Use	the	Insert	panel	or	the	Insert	menu	to	create	a	new	table.	
Then,	add	text	and	images	to	table	cells	the	same	way	that	you	add	
text	and	images	outside	of	a	table.
In	the	Design	view	of	the	Document	window,	place	the	insertion	
point	where	you	want	the	table	to	appear.

Note:	If	your	document	is	blank,	you	can	place	the	insertion	point	
only	at	the	beginning	of	the	document.
Select	Insert	>	Table.

Note: The Layout mode feature is deprecated as of Dreamweaver CS4 and 
 later. Layout mode created page layouts using layout tables, which are no  
longer recommended by Adobe. For more information on Layout mode and 
why it was deprecated, see the Dreamweaver Team Blog.

In	the	Common	category	of	the	Insert	
panel,	click	Table.
Set	the	attributes	of	the	Table	dialog	
box	and	click	OK	to	create	the	table.
Rows	Determines	the	number	of	table	
rows.
Columns	Determines	the	number	of	
table	columns.
Table Width	Specifies	the	width	of	
the	table	in	pixels,	or	as	a	percentage	
of	the	browser	window’s	width.
Border Thickness	Specifies	the	width,	
in	pixels,	of	the	table’s	borders.
Cell Spacing Determines	the	number	
of	pixels	between	adjacent	table	cells.
When	you	don’t	explicitly	assign	values	
for	border	thickness	or	cell	spacing	
and	cell	padding,	most	browsers	
display	the	table	border	thickness	and	
cell	padding	set	to	1	and	cell	spacing	
were	set	to	2.	To	ensure	that	browsers	
display	the	table	with	no	border,	pad-
ding	or	spacing,	set	Cell	Padding	and	
Cell	Spacing	to	0.
Cell Padding	Determines	the	number	
of	pixels	between	a	cell’s	border	and	
its	contents.
None	Does	not	enable	column	or	row	
headings	for	the	table.
Left	Makes	the	first	column	of	the	
table	a	column	for	headings,	so	that	
you	can	enter	a	heading	for	each	row	
of	the	table.
Top	Makes	the	first	row	of	the	table	
a	row	for	headings,	so	that	you	can	
enter	a	heading	for	each	column	of	
the	table.
Both Enables	you	to	enter	column	and	
row	headings	in	the	table.
It’s	a	good	idea	to	use	headers	in	case	
any	of	your	website	visitors	use	screen	
readers.	Screen	readers	read	table	
headings	and	help	screen-reader	users	
keep	track	of	table	information.
Caption	Provides	a	table	title	which	
displays	outside	of	the	table.
Align Caption	Specifies	where	the	
table	caption	appears	in	relation	to	the	
table.
Summary	Provides	a	table	description.	
Screen	readers	read	the	summary	text,	
but	the	text	does	not	appear	in	the	
user’s	browser.
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Import and export tabular data

You	can	import	tabular	data	that	has	been	created	in	another		
application	(such	as	Microsoft	Excel)	and	saved	in	a	delimited	text	
format	(with	items	separated	by	tabs,	commas,	colons,	or		
semicolons)	into	Dreamweaver	and	format	it	as	a	table.
You	can	also	export	table	data	from	Dreamweaver	into	a	text	file,	
with	the	contents	of	adjacent	cells	separated	by	a	delimiter.	You	
can	use	commas,	colons,	semicolons,	or	spaces	as	delimiters.	When	
you	export	a	table,	the	entire	table	is	exported;	you	cannot	select	
portions	of	a	table	to	export.
If	you	want	only	some	of	the	data	from	a	table—for	example,	the	
first	six	rows	or	the	first	six	columns—then	copy	the	cells	contain-
ing	that	data,	paste	those	cells	outside	of	the	table	(to	create	a	
new	table),	and	export	the	new	table.
Import	table	data
Do	one	of	the	following:
Select	File	>	Import	>	Tabular	Data.
In	the	Data	category	of	the	Insert	panel,	click	the	Import	Tabular	
Data	icon	.
Select	Insert	>	Table	Objects	>	Import	Tabular	Data.
Specify	the	options	for	the	tabular	data	and	click	OK.
Data	File	The	name	of	the	file	to	import.	Click	the	Browse	button	to	
select	a	file.
Delimiter	The	delimiter	used	in	the	file	you’re	importing.
If	you	select	Other,	a	text	box	appears	to	the	right	of	the	pop-up	
menu.	Enter	the	delimiter	used	in	your	file.

Note: Specify the delimiter that was 
used when the data file was saved. If 
you don’t do this, the file will not be 
imported properly, and your data will 
not be correctly formatted in a table.
Table Width The width of the table.

Select	Set	to	specify	a	fixed	table	width	
in	pixels	or	as	a	percentage	of	the	
browser	window’s	width.

Border	Specifies	the	width,	in	pixels,	of	
the	table’s	borders.
Cell Padding The	number	of	pixels	
between	a	cell’s	content	and	the	cell	
boundaries.
Cell Spacing	The	number	of	pixels	
between	adjacent	table	cells.
If	you	don’t	explicitly	assign	values	for	
borders,	cell	spacing,	and	cell	padding,	
most	browsers	display	the	table	with	
borders	and	cell	padding	set	to	1,	and	
cell	spacing	set	to	2.	To	ensure	that	
browsers	display	the	table	with	no		
padding	or	spacing,	set	Cell	Padding	
and	Cell	Spacing	to	0.		
To	view	cell	and	table	boundaries	when	
the	border	is	set	to	0,	select	View	>	
Visual	Aids	>	Table	Borders.
Format Top Row Determines	what	
formatting,	if	any,	is	applied	to	the	top	
row	of	the	table.	Select	from	four		
formatting	options:	no	formatting,	
bold,	italic,	or	bold	italic.

Export a table
Place	the	insertion	point	in	any	cell	of	
the	table.
Select	File	>	Export	>	Table.
Specify	the	following	options:
Delimiter Specifies	which	delimiter	
character	should	be	used	to	separate	
items	in	the	exported	file.
Line Breaks	Specifies	which	operating	
system	you’ll	be	opening	the	exported	
file	in:	Windows,	Macintosh,	or	UNIX.	
(Different	operating	systems	have	
different	ways	of	indicating	the	end	of	
a	line	of	text.)
Click	Export.
Enter	a	name	for	the	file	and	click	Save.
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Creating and Formatting Lists
Lists	organize	the	everyday	information	of	our	lives:	to-do	lists,	
grocery	lists,	least	favorite	celebrity	lists,	and	so	on.	On	web	pages,	
lists	are	indispensable	for	presenting	groups	of	items,	such	as	links,	
company	services,	or	sets	of	instructions.
 
Bulleted and Numbered Lists
Bulleted	and	numbered	lists	share	similar	formatting.		
Dreamweaver	automatically	indents	list	items	in	both	cases,	and	
automatically	precedes	each	item	with	a	character—a	bullet,		
number,	or	letter,	for	example:
•	Unordered,	or	bulleted,	lists,	like	this	one,are	good	for	groups	of	
items	that	don’t	necessarily	follow	a	sequence.	Browsers	precede	
each	list	item	with	a	bullet.
•	Ordered	lists	are	useful	when	you	want	to	present	items	that	
follow	a	sequence,	such	as	the	numbered	instructions	in	the	
section	below.	Instead	of	a	bullet,	a	number	or	letter	precedes	
each	item	in	an	ordered	list.	Dreamweaver	suggests	a	number	(1,	2,	
3,	and	so	on),	but	you	can	substitute	Roman	numerals,	letters,	and	
other	variations.
You	can	create	a	list	from	scratch	within	Dreamweaver,	or	apply	list	
formatting	to	text	that’s	already	on	a	page.
	
CREATING A NEW BULLETED OR NUMBERED LIST
When	you	make	a	new	list	in	Dreamweaver,	first	choose	a	list		
format,	and	then	type	in	the	list	items:
1.	In	Design	view	in	the	document	window,	click	the	point	on	a	
page	where	you	want	to	start	the	list.
2.	In	the	Property	Inspector,	click	the	Ordered	List	or	Unordered	
List	button	to	apply	the	list	format	(The	Unordered	option	is	also	
known	as	a	bulleted	list.)
Alternatively,	you	can	choose	Format>List>Unordered	List	or		
Ordered	List.	Either	way,	the	first	bullet	or	number	appears		
automatically	in	your	document.
3.	Type	in	the	first	list	item,	and	then	press	Enter	(Return).	Repeat	
this	step	until	you	add	all	the	items	in	the	list.
The	text	you	type	appears	after	the	bullet	or	number.	When	you	
press	Enter	(Return),	a	new	bullet	or	number	appears,	ready	for	
your	next	item.	(If	you	just	want	to	move	to	the	next	line		
without	creating	a	new	bullet,	then	insert	a	line	break	by	pressing	
Shift+Enter	[Shift-Return].)
4.	When	you	finish	the	list,pressEnter(Return)twice.
The	double	hard	return	ends	the	list	and	creates	a	new	empty	para-
graph.

HTML	offers	formatting	options	for	
three	basic	types	of	lists.	The	two	most	
common	are	bulleted	lists	(called	unor-
dered	lists	in	HTML)	and	numbered	lists	
(called	ordered	lists	in	HTML).	The	third	
and	lesser-known	list	type,	the	defi-
nition	list,	comes	in	handy	when	you	
want	to	create	glossaries	or	dictionary	
entries.

HTML	has	several	predefined	list	for-
mats	that	let	you	organize	information	
into	orderly	units.	Once	you	tell		
Dreamweaver	that	you	intend	to	create	
a	bulleted,	numbered,	or	definition	list,	
it	automatically	adds	the	bullets,		
numbers,	or	word/definition		
formatting	for	you.	(You’ll	find	
definition	lists	discussed	in	the	next	
section.)
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FORMATTING EXISTING TEXT AS A LIST
You	may	have	several	paragraphs	of	text	you	already	typed	up	or	
pasted	in	from	another	program.	You	can	easily	change	any	such	
group	of	paragraphs	into	a	list:
1.	Select	the	text	you	wish	to	turn	in	to	a	list.
The	easiest	way	to	do	this	is	to	drag	from	the	first	list	item	straight	
down	to	the	last	one.	Lists	are	block-level	elements;	each		
paragraph,	whether	it’s	a	headline	or	a	regular	block	of	text,		
becomes	one	bulleted	or	numbered	item	in	the	list.
NOTE  You can use the Property Inspector to change existing  
text in to a list in Code view as well.
2.	Apply	the	list	format.
Just	as	you	created	a	list	from	scratch	as	described	above,	click	
either	the	Unordered	List	or	Ordered	List	button	in	the	Property	
Inspector,	or	choose	from	the	Format>List	submenu.	The	selected	
paragraphs	instantly	take	on	the	list	formatting,	complete	with	
bullets	or	automatic	numbering.
	
Whichever	way	you	create	your	list—either	by	typing	it	in	from	
scratch	or	format-	ting	existing	text—you’re	not	stuck	with	the		
results	of	your	early	decisions.	You	can	add	onto	lists,	add	extra	
spaces,	and	even	renumber	them,	as	described	in	the	following	
section.
REFORMATTING BULLETED AND NUMBERED LISTS
HTML	tags	define	lists,	just	as	they	define	other	web	page	ele-
ments.	Making	changes	to	an	existing	list	is	a	matter	of	changing	
those	tags,	using	Dreamweaver’s	menu	commands	and	Property	
Inspector.

TIP:	Web	browsers	generally	display	list	items	stacked	directly	one	on	top	of	the	
other.	If	you	want	to	add	a	little	breathing	room	between	each	item,	use	the	CSS	
margin	property	to	add	space	above	or	below	<li>	tags

ADDING NEW ITEMS TO A LIST
Once	you	create	a	list,	you	can	easily	add	items.	To	add	an	item	at	
the	beginning	of	a	list,	click	in	front	of	the	first	character	of	the	
first	list	item	(not	its	bullet	or	number),	type	the	item	you	wish	to	
add,	and	then	press	Enter	(Return).	Your	first	item	now	sits	beside	
the	first	bullet	or	number,	and	pressing	the	Enter	(Return)	key	
automatically	generates	the	next	bullet	or	number	(and	renumbers	
the	other	list	items,	if	necessary).
	

NOTE  You can use the Property 
Inspector to create a numbered or bul-
leted list in Code view, but  
Dreamweaver won’t automatically add 
a new list item each time you hit return. 
To insert a new list item, you must click 
outside the current list item (either 
before an opening <li> or after a closing 
</li>) and either choose Insert>HTML.> 
Text Object>List Item, or just type the 
HTML yourself (for example: <li>New 
item</li>). As you can see, using Design 
view to add lists is a lot easier. The only 
benefit of the Code view is that you can 
insert paragraphs, headlines and other 
elements inside the <li> tags, which is 
perfectly valid HTML, but which  
Dreamweaver doesn’t let you do in 
Design view.

NOTE  You may sometimes run into this 
problem: You select what looks like a 
handful of paragraphs and apply the list 
format, but only one bullet (or number) 
appears. This glitch arises when you 
use the line break <br> tag to move 
text down a line in a paragraph. While 
it’s true that using the <br> tag visually 
separates lines in a paragraph into sep-
arate blocks, the text is still part of a 
single paragraph, and it appears as only 
one bulleted or numbered item. The 
presence of multiple <br> tags can be a 
real problem when you paste text from 
other programs. See page 93 for more 
on the <br> tag and how to get rid of 
these pesky critters.
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Insert and edit images

Insert an image
When	you	insert	an	image	into	a	Dreamweaver	document,	a	ref-
erence	to	the	image	file	is	generated	in	the	HTML	source	code.	
To	ensure	that	this	reference	is	correct,	the	image	file	must	be	in	
the	current	site.	If	it	is	not	in	the	current	site,	Dreamweaver	asks	
whether	you	want	to	copy	the	file	into	the	site.
You	can	also	insert	images	dynamically.	Dynamic	images	are	those	
images	that	change	often.	For	example,	advertising	banner		
rotation	systems	need	to	randomly	select	a	single	banner	from	a	
list	of	potential	banners,	and	then	dynamically	display	the	selected	
banner’s	image	when	a	page	is	requested.
After	you	insert	an	image,	you	can	set	image	tag	accessibility		
attributes	that	can	be	read	by	screen	readers	for	visually	impaired	
users.	These	attributes	can	be	edited	in	HTML	code.

1.	 Place	the	insertion	point	where	you	want	the	image	to	appear	
in	the	Document	window	and	do	one	of	the	following:

•	 In	the	Common	category	of	the	Insert	panel,	click	the	Images	icon	.
•	 In	the	Common	category	of	the	Insert	panel,	click	the	Images	button	and	

select	the	Image	icon.	With	the	Image	icon	displayed	in	the	Insert	panel,	you	
can	drag	the	icon	to	the	Document	window	(or	to	the	Code	view	window	if	
you	are	working	in	the	code).

•	 Select	Insert	>	Image.
•	 Drag	an	image	from	the	Assets	panel	(Window	>	Assets)	to	the	desired	

location	in	the	Document	window;	then	skip	to	step	3.
•	 Drag	an	image	from	the	Files	panel	to	the	desired	location	in	the	Document	

window;	then	skip	to	step	3.
•	 Drag	an	image	from	the	desktop	to	the	desired	location	in	the	Document	

window;	then	skip	to	step	3.
2.	 In	the	dialog	box	that	appears,	do	one	of	the	following:
•	 Select	File	System	to	choose	an	image	file.
•	 Select	Data	Source	to	choose	a	dynamic	image	source.
•	 Click	the	Sites	And	Servers	button	to	choose	an	image	file	in	a	remote	folder	

of	one	of	your	Dreamweaver	sites.
3.	 Browse	to	select	the	image	or	content	source	you	want	to	

insert.
•	 If	you	are	working	in	an	unsaved	document,	Dreamweaver	generates	a	file://	

reference	to	the	image	file.	
•	 When	you	save	the	document	anywhere	in	the	site,	Dreamweaver	converts	

the	reference	to	a	document-relative	path.

4.	 Click	OK.	The	Image	Tag	Accessibility	Attributes	dialog	box		
appears	if	you	have	activated	the	dialog	box	in	Preferences	
(Edit	>	Preferences).

Many	different	types	of	graphic	file	
formats	exist,	but	three	graphic	file	
formats	are	generally	used	in	web	pag-
es—GIF,	JPEG,	and	PNG.	GIF	and	JPEG	
file	formats	are	the	best	supported	and	
can	be	viewed	in	most	browsers.	You	
can	easily	insert	images	and	edit	them	
using	the	Dreamweaver	user	interface.

GIF	(Graphic	Interchange	Format)

GIF	files	use	a	maximum	of	256	colors,	
and	are	best	for	displaying	noncontin-
uous-tone	images	or	those	with	large	
areas	of	flat	colors,	such	as	navigation	
bars,	buttons,	icons,	logos,	or	other	
images	with	uniform	colors	and	tones.

JPEG	(Joint	Photographic	Experts	
Group)

The	JPEG	file	format	is	the	superior	
format	for	photographic	or	continu-
ous-tone	images,	because	JPEG	files	
can	contain	millions	of	colors.	As	the	
quality	of	a	JPEG	file	increases,	so	does	
the	file	size	and	the	file	download	time.	
You	can	often	strike	a	good	balance	be-
tween	the	quality	of	the	image	and	the	
file	size	by	compressing	a	JPEG	file.

PNG (Portable	Network	Group)

The	PNG	file	format	is	a	patent-free	
replacement	for	GIFs	that	includes	
support	for	indexed-color,	gray	scale,	
and	true-color	images,	and	alpha	
channel	support	for	transparency.	PNG	
is	the	native	file	format	of	Adobe®	
Fireworks®.	PNG	files	retain	all	the	
original	layer,	vector,	color,	and	effects	
information	(such	as	drop	shadows),	
and	all	elements	are	fully	editable	at	
all	times.	Files	must	have	the	.png	file	
extension	to	be	recognized	as	PNG	files	
by	Dreamweaver.



28

Dreamweaver CS6

5.	 Enter	values	in	the	Alternate	Text	and	Long	Description	text	
boxes,	and	click	OK.

•	 In	the	Alternate	Text	box,	enter	a	name	or	brief	description	for	the	image.	
The	screen	reader	reads	the	information	you	enter	here.	You	should	limit	
your	entry	to	around	50	characters.	For	longer	descriptions,	consider	provid-
ing	a	link,	in	the	Long	Description	text	box,	to	a	file	that	gives	more	informa-
tion	about	the	image.

•	 In	the	Long	Description	box,	enter	the	location	of	a	file	that	displays	when	
the	user	clicks	the	image	or	click	the	folder	icon	to	browse	to	the	file.	This	
text	box	provides	a	link	to	a	file	that	is	related	to,	or	gives	more	information	
about,	the	image.

Note:
You	can	enter	information	in	one	or	both	text	boxes	depending	on	
your	needs.	The	screen	reader	reads	the	Alt	attribute	for	the	
image.

Note:
If	you	click	Cancel,	the	image	appears	in	the	document,	but	Dream-
weaver	does	not	associate	accessibility	tags	or	attributes	with	it.
In	the	Property	inspector	(Window	>	Properties),	set	properties	for	
the	image.

Note:
When	inserting	images	it’s	also	possible	
to	use	an	absolute	path	to	an	image	
that	resides	on	a	remote	server		
(i.e.,	an	image	that	is	not	available	on	
the	local	hard	drive).	If	you	experience		
performance	problems	while	working,	
however,	you	might	want	to	disable	
viewing	the	image	in	Design	view	by		
deselecting	Commands	>	Display	Exter-
nal	Files.
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Wrap-up

Upon	completing	this	workshop,	you	should	be	able	to	do	the	
following:

•	 Insert	Import	Word	Documents	(Windows)
•	 Insert	Tables	and	Modify	them
•	 Insert	Images


