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	 Topics
•	 �Creating and opening 

documents
•	 CSS Style Panel
•	 �Apply, remove, or 	

rename CSS class styles
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About creating Dreamweaver 
documents

Dreamweaver offers a flexible environment for working with 
a variety of web documents. In addition to HTML documents, 
you can create and open a variety of text-based documents, 
including ColdFusion Markup Language (CFML), ASP, JavaS-
cript, and Cascading Style Sheets (CSS). Source code files, 
such as Visual Basic, .NET, C#, and Java, are also supported.
Dreamweaver provides several options for creating a new 
document. You can create any of the following:

•	 A new blank document or template
•	 A document based on one of the predesigned page lay-

outs that comes with Dreamweaver, including over 30 
CSS-based page layouts

•	 A document based on one of your existing templates
•	 You can also set document preferences. For example, if 

you typically work with one type of document, you can set 
it as the default document type for new pages you create.

•	 You can easily define document properties, such as meta 
tags, document title, and background colors, and several 
other page properties in either Design view or Code view.

Create a layout using a blank page

You can create a page that contains a predesigned CSS lay-
out, or create a completely blank page and then create a 
layout of your own.

Select File > New.

Dreamweaver 
file types
You can work with a variety of file types 
in Dreamweaver. The primary kind 
of file you will work with is the HTML 
file. HTML files—or Hypertext Markup 
Language files—contain the tag-based 
language responsible for displaying a 
web page in a browser. You can save 
HTML files with either the .html or .htm 
extension. 
Following are some of the other com-
mon file types you might use when 
working in Dreamweaver:
CSS
Cascading Style Sheet files have a .css 
extension. They are used to format 
HTML content and control the position-
ing of various page elements.
GIF
Graphics Interchange Format files have 
a .gif extension. GIF format is a popular 
web graphic format for cartoons, logos, 
graphics with transparent areas, and 
animations. GIFs contain a maximum of 
256 colors.
JPEG
Joint Photographic Experts Group files 
(named after the organization that 
created the format) have a .jpg exten-
sion, and are usually photographs or 
high-color images. The JPEG format 
is best for digital or scanned photo-
graphs, images using textures, images 
with gradient color transitions, and 
any images that require more than 256 
colors.
XML
Extensible Markup Language files have 
a .xml extension. They contain data in a 
raw form that can be formatted using 
XSL (Extensible Stylesheet Language).
XSL
Extensible Stylesheet Language files 
have a .xsl or .xslt extension. They are 
used to style XML data that you want 
to display on a web page.
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In the Blank Page category of the New Document dialog box, 
select the kind of page you want to create from the Page Type 
column. For example, select HTML to create a plain HTML page.

If you want your new page to contain a CSS layout, select a pre-
designed CSS layout from the Layout column; otherwise, select 
None. Based on your selection, a preview and description of the 
selected layout appears on the right side of the dialog box.
The predesigned CSS layouts provide the following types of 
columns:

Fixed
Column width is specified in pixels. The column does not resize 
based on the size of the browser or the site visitor’s text set-
tings.

Liquid
Column width is specified as a percentage of the site visitor’s 
browser width. The design adapts if the site visitor makes the 
browser wider or narrower, but does not change based on the 
site visitor’s text settings.

Dreamweaver also offers two HTML5 CSS layouts: two- and 
three-column fixed.

Note:
In Dreamweaver CC and later, only HTML5 CSS layouts are avail-
able.
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Select a document type from the DocType pop-up menu. In most 
cases, you can use the default selection, XHTML 1.0 Transitional or 
HTML5 (Dreamweaver CC).

If you selected a CSS layout in the Layout column, select a location 
for the layout’s CSS from the Layout CSS pop-up menu.

Add To Head
Adds CSS for the layout to the head of the page you’re creating.

Create New File
Adds CSS for the layout to a new external CSS file and attaches the 
new style sheet to the page you’re creating.

Link To Existing File
Lets you specify an existing CSS file that already contains the CSS 
rules needed for the layout. To do this, click the Attach Style Sheet 
icon above the Attach CSS file pane and select an existing CSS style 
sheet. This option is particularly useful when you want to use the 
same CSS layout (the CSS rules for which are contained in a single 
file) across multiple documents.

(Optional) You can also attach CSS style sheets to your new page 
(unrelated to the CSS layout) when you create the page. To do this, 
click the Attach Style Sheet icon  above the Attach CSS File pane 
and select a CSS style sheet.

Click the Create button.

Save the new document (File > Save).

In the dialog box that appears, navigate to the folder where you 
want to save the file.
It’s a good idea to save your file in a Dreamweaver site.

In the File Name box, type a name for the file.	
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CSS Style Panel
Note: In Dreamweaver CC and later, CSS Styles panel is replaced with CSS 
Designer. 

The CSS Styles panel lets you track the CSS rules and properties 
affecting a currently selected page element (Current mode), or 
all of the rules and properties that are available to the document 
(All mode). A toggle button at the top of panel lets you switch 
between the two modes. The CSS Styles panel also lets you modify 
CSS properties in both All and Current mode.

The CSS Styles panel in Current mode
In Current mode, the CSS Styles panel displays three panes: a Sum-
mary for Selection pane that displays the CSS properties for the 
current selection in the document, a Rules pane that displays the 
location of selected properties (or a cascade of rules for the select-
ed tag, depending on your selection), and a Properties pane that 
lets you edit CSS properties for the rule applied to the selection.

The CSS panel in Current mode, displays three panes: the CSS prop-
erties for the current selection, the location of selected properties 
and a place to edit the CSS properties for that rule.
You can resize any of the panes by dragging the borders between 
the panes, and can resize columns by dragging dividers.

The Summary for Selection pane displays a summary of CSS prop-
erties and their values for the item currently selected in the active 
document. The summary shows the properties for all rules that 
directly apply to the selection. Only set properties are shown.

The Rules pane displays two different views—About view or Rules 
view—depending on your selection. In About view (the default 
view), the pane displays the name of the rule that defines the se-
lected CSS property, and the name of the file containing the rule. 
In Rules view, the pane displays a cascade, or hierarchy, of all rules 
that apply directly or indirectly to the current selection. (The tag 
to which the rule directly applies appears in the right column.) You 
can toggle between the two views by clicking the Show Informa-
tion and Show Cascade buttons in the upper-right corner of the 
Rules pane.

CSS Styles panel in Current mode
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In all views, set properties are displayed in blue; properties irrel-
evant to a selection are displayed with a red strike-through line. 
Holding the mouse over a rule that is irrelevant displays a message 
explaining why the property is irrelevant. Typically a property is 
irrelevant because it’s overridden or not an inherited property.
Any changes you make in the Properties pane are applied immedi-
ately, letting you preview your work as you go.

The CSS Styles panel in All mode

In All mode, the CSS Styles panel displays two panes: an All Rules 
pane (on top), and a Properties pane (on bottom). The All Rules 
pane displays a list of rules defined in the current document as 
well as all rules defined in style sheets attached to the current 
document. The Properties pane lets you edit CSS properties for any 
selected rule in the All Rules pane.
The CSS Styles panel in All mode, showing two panes: All Rules and 
Properties for any selected rule.
You can resize either pane by dragging the border between the 
panes, and can resize the Properties columns by dragging their 
divider.
When you select a rule in the All Rules pane, all of the properties 
that are defined in that rule appear in the Properties pane. You can 
then use the Properties pane to quickly modify your CSS, whether 
it is embedded in the current document or linked in an attached 
style sheet. By default, the Properties pane shows only those 
properties that have been previously set, and arranges them in
alphabetical order.
You can choose to display properties in two other views. Category 
view displays properties grouped into categories, such as Font, 
Background, Block, Border, and so on, with set properties at the 
top of each category. List view displays an alphabetical list of all 
available properties, and likewise sorts set properties to the top. 
To switch between views, click the Show Category View, Show List 
View, or Show Only Set Properties button, located at the lower-left 
corner of the Properties pane. In all views, set properties are dis-
played in blue.
Any changes you make in the Properties pane are applied immedi-
ately, letting you preview your work as you go.

CSS Styles panel in All mode
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Note: In Dreamweaver CC and later, CSS Styles panel is replaced 
with CSS Designer. 	
Class styles are the only type of CSS style that can be applied to any 
text in a document, regardless of which tags control the text. All 
class styles associated with the current document are displayed in 
the CSS Styles panel (with a period [.] preceding their name) and in 
the Style pop‑up menu of the text Property inspector.
You’ll see most styles updated immediately, however, you should 
preview your page in a browser to verify a style was applied as 
expected. When you apply two or more styles to the same text, the 
styles may conflict and produce unexpected results.
When previewing styles defined in an external CSS style sheet, be 
sure to save the style sheet to ensure that your changes are reflect-
ed when you preview the page in a browser.

Apply a CSS class style

1.	 �In the document, select the text to which you want to apply a 
CSS style.	
Place the insertion point in a paragraph to apply the style to the 
entire paragraph.	
If you select a range of text within a single paragraph, the CSS 
style affects only the selected range. 	
To specify the exact tag to which the CSS style should be ap-
plied, select the tag in the tag selector located at the lower left 
of the Document window.	

2.	 To apply a class style, do one of the following:
•	 In the CSS Styles panel (Window > CSS Styles), select All 

mode, right-click the name of the style you want to apply, 
and select 

•	 Apply from the context menu.
•	 In the HTML Property inspector, select the class style you 

want to apply from the Class pop‑up menu.
•	 In the Document window, right-click (Win) or Control‑click 

(Mac) the selected text, and in the context menu, select CSS 
Styles and then select the style you want to apply.

•	 Select Format > CSS Styles, and in the submenu select the 
style you want to apply.

CSS Styles panel
buttons and views
In both All and Current modes, the CSS 
Styles panel contains three buttons that 
let you alter the view in the Properties 
pane (the bottom pane):

A. Category View
B. List View	
C. Set Properties View

Category View 
Divides the Dreamweaver-supported CSS 
properties into eight categories: 
font, background, block, border, box, list, 
positioning, and extensions. 
Each category’s properties are contained 
in a list that you expand or collapse by 
clicking the Plus (+) button next to the 
category name. 
List View
Displays all of the Dreamweaver-support-
ed CSS properties in alphabetical order. 
Set Properties View
Displays only those properties that have 
been set. Set Properties view is the de-
fault view.

Open the CSS Styles panel

•	 You use the CSS Styles panel to 
view, create, edit, and remove CSS 
styles, as well as to attach external 
style sheets to documents.

•	 Do one of the following:	
Select Window > CSS Styles.

•	 Press Shift+F11.
•	 Click the CSS button in the Proper-

ty inspector.

A	 B	 C



16

Dreamweaver CS6

Remove a class style from a selection
Select the object or text you want to remove the style from.
In the HTML Property inspector (Window > Properties), select None 
from the Class pop‑up menu.

Rename a class style
In the CSS styles panel, right-click the CSS class style you want to 
rename and select Rename Class.
You can also rename a class by selecting Rename Class from the 
CSS Styles panel options menu.
In the Rename Class dialog box, make sure that the class you want 
to rename is selected in the Rename Class pop‑up menu.
In the New Name text box, enter the new name for the new class 
and click OK.
If the class you’re renaming is internal to the head of the current 
document, Dreamweaver changes the class name as well as all 
instances of the class name in the current document. If the class 
you’re renaming is in an external CSS file, Dreamweaver opens and 
changes the class name in the file. Dreamweaver also launches a 
site-wide Find and Replace dialog box so that you can search for all 
instances of the old class name in your site.

CSS Styles panel
buttons and views CONT.
In both All and Current modes, the CSS 
Styles panel also contains the following 
buttons:

A. Attach Style Sheet
B. New CSS Rule
C. Edit Style
D. Disable/enable CSS property
E. Delete CSS rule

Attach Style Sheet 
Opens the Link External Style Sheet 
dialog box. Select an external style sheet 
to link to or import into your current 
document.
New CSS Rule 
Opens a dialog box in which you can se-
lect the type of style you’re creating—for 
example, to create a class style, redefine 
an HTML tag, or to define a CSS selector.
Edit Style 
Opens a dialog box in which you can edit 
the styles in the current document or in 
an external style sheet.
Delete CSS Rule Removes the selected 
rule or property from the CSS Styles 
panel, and removes the formatting from 
any element to which it was applied. (It 
does not, however, remove class or ID 
properties referenced by that style). 
The Delete CSS Rule 
button can also detach (or “unlink”) an 
attached CSS style sheet.

A  B  C  D  E
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Wrap-up

Upon completing this workshop, you should be able to do the 
following:

•	 Open and Close Layouts 
•	 Manage CSS rules using the CSS Styles panel
•	 Move CSS rules to an external style sheet


